SWIV 3D Can't Read CD-ROM :(

Post problems with getting games installed and running properly here.
Post Reply
andy083

SWIV 3D Can't Read CD-ROM :(

Post by andy083 » Sat Jun 30, 2007 12:02 pm

Hi all,

Really hope someone can help here - when i try to run swiv 3d in MS DOS, the game begins to start, but then fails and claims there is no "CD-ROM!"

The CD is in the drive - so was hoping someone might have an idea whats going wrong :(

Cheers A

User avatar
Larry Laffer
Admin
Admin
Posts: 4143
Joined: Sun Feb 19, 2006 8:06 am
Location: Romania

Post by Larry Laffer » Sat Jun 30, 2007 12:05 pm

Are we talking about real MS DOS mode or DOSBox here?
<center>
abyss wrote:I don't even know if starcraft 1 was a windows or dos games.
</center>

ModBot™ - Faster than the speed of spam!(and always taking it to where it belongs!)

andy083

Post by andy083 » Sat Jun 30, 2007 12:45 pm

Yeah I am trying to run the game in DOSBox - get the same error if in that and the command prompt in windows XP :(

Must have missed something...

User avatar
dosraider
Admin
Admin
Posts: 9243
Joined: Tue Mar 15, 2005 2:06 pm
Location: ROTFLMAO in Belgium.

Post by dosraider » Sat Jun 30, 2007 1:00 pm

Add this line in dosbox:

mount d X:\ -t cdrom -ioctl

The X is your real drive letter in windows.

That should do it, you will have the CDDrive as D in dosbox.

*Edit: you still must mount a C in dosbox, of course.

andy083

Thanks

Post by andy083 » Sun Jul 01, 2007 6:42 am

Thanks a lot - thats seems to have fixed it :)

Post Reply