Page 1 of 1

Could not use the floppy drive! Help me!

Posted: Wed Aug 31, 2005 2:12 pm
by fabiobol
Well, I have a problem that seems to be very very strange. I'm not so good in English, but I will try to explain everything as good as i can: on my P200 MMX, 256 MB RAM, with MB SOLTEK 54U5, I installed Windows 2000 and XP a lot of times, and it ran always very well, also the fdd worked well! For some reasons, I decided to downgrade to Windows 98 for a period. Last week, I decided then to format the HDD (a Seagate 12 GB) and re-install Windows XP. Everything happened successfully but... when I clicked on "My computer" the Floppy drive disappeared! I tried a lot of times also with Windows 2000, but nothing changed. It seems that I can use floppy only on Windows 95/98/ME/DOS. When I returned to windows ME, the floppy drive and the controller were correctly detected and, at the moment, I'm using it. Soltek told me that the chipset isn't compatible with Windows XP but I said to me: "If it ran before, why now it doesn't work?".

Posted: Wed Aug 31, 2005 8:44 pm
by Wally
Did you format again before you installed XP

Posted: Thu Sep 01, 2005 7:13 am
by fabiobol
Of course, I formatted the C:\ drive. I tried it a lot of times, but the result was always the same!

Posted: Fri Sep 02, 2005 4:45 am
by Wally
Im guessing you have to buy a new floppy drive..

They arent that expensive really

Posted: Fri Sep 02, 2005 7:38 am
by fabiobol
I tried. But do you believe me if I tell you that it isn't detected at all? Anyway, it isn't the floppy drive that is not detected, but the whole Floppy-disk controller! If I go to the system properties, the device "floppy disk controller" (or something like that) is missing, while, on Windows ME at the moment, is working and well! I tried XP for the first times 2 months ago on this PC, but then the FDD worked very well! In my opinion, there aren't any possible solutions!

Posted: Fri Sep 02, 2005 9:22 am
by jmmijo
It does sound like perhaps the FDC is flaking out. Have you tried out a new floppy data cable yet ?!?

Posted: Fri Sep 02, 2005 9:52 am
by fabiobol
Of course, but you may easily know that, if under Windows 9x/ME the FDD works, it probably won't be an hardware problem, but i think a software problem! But... what can I do? I remember that it worked!