Computer hard drive issues

Want to talk about your hardware setup? Brag about your super-machine's layout? Pretend you know a lot about computers? You can do all that and more in this forum.
Post Reply
User avatar
Aldeb
Expert
Expert
Posts: 128
Joined: Sat Mar 15, 2014 1:03 pm

Computer hard drive issues

Post by Aldeb »

Hello. I have an old Win98 PC. When it boots up, it will sometime detect the two hard drives but will then write 'primary drive failure'. My only solution to this is to restart until it boots up correctly

this always happens after all drives are detected at startup. The HDD never crashes after the computer boots and windows is running.

What could it be? is the HDD failing or can it be the power supply? i have 2 HDD, one is a primary 4GB and a secondary 20 GB
User avatar
Quadko
Darklander
Darklander
Posts: 2092
Joined: Fri Jun 24, 2011 10:07 am

Post by Quadko »

I've had computers that acted similarly, not necessarily with drives - if it booted, it was stable, but it wouldn't always boot. I assumed it was chip or electronic component related, but that was as wild a guess as yours are. :)

I have another computer who's bios battery/connection is dead (new battery didn't help), and it always takes booting two or three times before the computer has enough juice to be happy.

As far as the actual behavior you are seeing, I think the computer sends an init/request code of some sort to the drive during the back&forth initialization conversation they have, and doesn't get an answer it likes back, so errors out and "turns the drive off". On an eventual reboot the drive returns a good init response, and all is good since the drive is probably OK other than "warming up" the electronics fast enough. Of course, if you have any data on the drive you care about, you might copy it off while you can. This behavior could last for many years or this might mean the drive is going the way of all flesh soon.

Someone with more experience might be able to diagnose it as a tired or blown capacitor, cold silicon or other mysterious electronic issue I know nothing about. I hear funny stuff happens when capacitors go bad, in particular. They store and provide power, so a few boot sequences later there can be enough juice in the system to power up - I had a TV go bad like that, wouldn't turn on at first but would after trying for 5 minutes, and happily the fix was to replace several cheap capacitors on the power board - worked perfectly after that. So I'm generalizing from that experience in part. They say one of the things that fixes old dead ZX Spectrums is replacing all the capacitors - sadly the surface mount caps are harder to test and detect than the old wired ones!

If it's an option, you could try those drives in another pc or another drive in that pc to try to figure out if the drive or the pc's controller is the problem. I suspect it is the drive, of course.
User avatar
dr_st
Way too much free time
Way too much free time
Posts: 377
Joined: Wed Jun 23, 2004 2:49 pm
Location: Absorbed into Clayface

Post by dr_st »

Intermittent problems such as what you describe are most often a motherboard issue. In your case, related to the hard drive controller. Could be a tired or blown capacitor as Quadko mentioned. If there is visible damage / degradation in one of the capacitors on the board - then replacing it with a new one will usually fix the issue.

Can also be a faulty cable, and that's easy and cheap to check/replace, so I would try there first.
User avatar
Aldeb
Expert
Expert
Posts: 128
Joined: Sat Mar 15, 2014 1:03 pm

Post by Aldeb »

Thanks. man i hope it's not a bad mobo. replacing that would mean the most amount of hassle
Certified 16-bit Troll
Post Reply