DOS Games Message Board
DOS Games Discussion
A message board to talk about DOS games, get help, and find old games.
Do NOT post warez or abandonware requests please
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


I cannot get keyboard to mount correctly [Win7-64]

 
Post new topic   Reply to topic    DOS Games Discussion Forum Index -> Get Games to Work
Author Message
sidbee2011 .
Guest






PostPosted: Sat Oct 13, 2012 1:04 pm     Post subject: I cannot get keyboard to mount correctly [Win7-64] Reply with quote

I am running Win7 Professional 64-bit. I have loaded DOSBOX after trying a number of alterations to the DOSBOX.CONF file, but no matter what I do with keyboardlayout=, I do not get a correct keyboard. I have tried setting keyboardlayout= to auto (the default), us103 and ux103.

I know the correct file is being loaded because all the MOUNT and other commands I entered at the [autoexec] section are being executed correctly.

Regardless of what I specify, "\" comes out "]", and the = key does nothing at all. Additionally, the Alt-key combinations I normally use do not come out correctly.

Does anyone have any idea how to fix this?
Back to top
sidbee2011
Newbie
Newbie


Offline
Joined: 13 Oct 2012
Posts: 1
Location: California

PostPosted: Sat Oct 13, 2012 2:13 pm     Post subject: More keyboard problems in Win7 Professional Reply with quote

1. Some characters have their upper and lower output mixed up. For example, "a" comes out okay but all other characters in that keyboard row come out in caps, so typing the entire row with CAPS LOCK set OFF results in "aSDFGHJKL". Similarly, the top and bottom rows come out as "QWerTYuioP" and "ZXcVBnM: respectively.

2. The caps lock has no effect whatever.

Good news: I have gotten the Alt- keys to work, so I can make "\" with Alt-92 and "=" with Alt-61.
Back to top
Quadko
Darklander
Darklander


Offline
Joined: 24 Jun 2011
Posts: 1995

PostPosted: Sat Oct 13, 2012 7:15 pm     Post subject: Reply with quote

I've had that key mapping problem on my laptop, and I had to use the keymapper (CTRL-F1) to fix the []\ keys. But I think I had to use the alt- trick to get the right keys mapped! After that it all worked great.

I don't know about the CAPSLOCK, though. Might be similar. Anyway, the problem is apparently that it doesn't get keys directly from the OS, but captures them lower down and translates them from codes to keys. Sadly, it isn't smart enough to get the keys right on our "exotic"?!?!? keyboards, apparently.
Back to top
dosraider
Admin
Admin


Offline
Joined: 15 Mar 2005
Posts: 9246
Location: ROTFLMAO in Belgium.

PostPosted: Sat Oct 13, 2012 7:55 pm     Post subject: Reply with quote

Hmmmm, there was a topic on Vogon about those keyb problems, will see if I can find it.

[Edit]
This:
http://vogons.zetafleet.com/viewtopic.php?t=18465

There are more keyb related topics @Vogon, but what a bloody search function on their board ..... pfffff, worthless
Back to top
Display posts from previous:   
Post new topic   Reply to topic    DOS Games Discussion Forum Index -> Get Games to Work All times are GMT - 5 Hours
Page 1 of 1

 
Free Windows games


Powered by phpBB © 2001, 2005 phpBB Group and Ask an Expert
Also powered by Darren and the other admin and mods' hard work! ;)