DOS Games Message Board
DOS Games Discussion
A message board to talk about DOS games, get help, and find old games.
Do NOT post warez or abandonware requests please
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
NEW! DOSGames.com has been massively upgraded to v2.0 with TONS of new features!
Check out the new design and dozens of new features including online play!


Wing Commander: Privateer/Righteous Fire (MS-DOS) Sound

 
Post new topic   Reply to topic    DOS Games Discussion Forum Index -> Get Games to Work
Author Message
Tombstone
Experienced Member
Experienced Member


Offline
Joined: 01 Jun 2003
Posts: 51

PostPosted: Sun Jun 01, 2003 3:54 pm     Post subject: Wing Commander: Privateer/Righteous Fire (MS-DOS) Sound Reply with quote

This is really getting on my nerves...

The game runs fine, the music plays just fine, but the digital audio sounds like my sound card is giving birth to a hippopotamus.

Wing Commander II runs perfectly fine, as does WC2 Special Ops 1 and 2.

I've tried using Sound Blaster PRO and Sound Blaster 16 for digital audio in the configuration, but I get the same result.

Has anyone else had this? What can I do to resolve this?
Back to top
Wally
King of the Carrot Flowers


Offline
Joined: 01 May 2003
Posts: 4627

PostPosted: Sun Jun 01, 2003 8:37 pm     Post subject: Game!!!! Reply with quote

What version of windows you running???? maybe the DMA settings arent right
try just general adlib it always works for me

Wally4000 the Violent kid
Back to top
Splodginator
Way too much free time
Way too much free time


Offline
Joined: 23 Apr 2003
Posts: 558
Location: Nowhere.

PostPosted: Mon Jun 02, 2003 5:02 am     Post subject: Reply with quote

Heres a list of possibilities in no particular order:

What are you using for Music? Try the same thing for Audio, and if that doesn't work, try using PC Speaker.
Or maybe its just the normal sound.
Is that just Wing Commander II or all games? It could be your soundcard
Back to top
Tombstone
Experienced Member
Experienced Member


Offline
Joined: 01 Jun 2003
Posts: 51

PostPosted: Mon Jun 02, 2003 1:26 pm     Post subject: Re: Game!!!! Reply with quote

wally4000 wrote:
What version of windows you running???? maybe the DMA settings arent right
try just general adlib it always works for me


Ummmm... I'm not running any version of Windows. (See signature below) I'm running MS-DOS 6.

I set the DMA channel in the game's sound configuration to the same value as it is in the "SET BLASTER" environment variable, just like all the other settings (I/O=220 IRQ=5 DMA=1).

frogboy_90 wrote:
What are you using for Music? Try the same thing for Audio, and if that doesn't work, try using PC Speaker.
Or maybe its just the normal sound.
Is that just Wing Commander II or all games? It could be your soundcard


The Music option is "Sound Blaster PRO/16", which works fine. For Digital Audio, my choices are, Sound Blaster PRO, Sound Blaster 16, Sound Blaster, Pro Audio Spectrum, ThunderBoard, and None.

As I'm sure you're aware, digitized audio will not port to a PC Speaker, so it's either one of the options above or I select "None", and that's really not a solution.

Every other game I have runs digitized audio just fine, including the other Origin games in the Wing Commander series (WC2, SO1, SO2, etc.). ONLY WC: Privateer and WC: Righteous Fire do this...
Back to top
Tombstone
Experienced Member
Experienced Member


Offline
Joined: 01 Jun 2003
Posts: 51

PostPosted: Tue Jun 03, 2003 12:36 am     Post subject: Issue Resolved... Reply with quote

Fortunately, the guys over at Wing Commander Revival knew exactly what to do... Congratulatory

My system had too much EMS memory allocated for Privateer to run properly. By adding "8192" to the EMM386.EXE line in my CONFIG.SYS, the issue was resolved. The digitized audio works just fine now.

Thanks to everyone here for thier assistance, too.
Back to top
wardrich
"Some Troll"


Offline
Joined: 14 Sep 2002
Posts: 3945
Location: Ontario Canada

PostPosted: Tue Jun 03, 2003 8:27 am     Post subject: Reply with quote

Quote:
but the digital audio sounds like my sound card is giving birth to a hippopotamus.

Laughing

glad to hear that you will no longer have to listen to that... Laughing
Back to top
Display posts from previous:   
Post new topic   Reply to topic    DOS Games Discussion Forum Index -> Get Games to Work All times are GMT - 5 Hours
Page 1 of 1

 


Powered by phpBB © 2001, 2005 phpBB Group and Ask an Expert
Also powered by Darren and the other admin and mods' hard work! ;)